import Foundation
let pattern = #"(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Kraus, Fritz R., (1968) 146
Owen, David I., (2013) 1156
Dalley, Stephanie & Yoffee, Norman, (1991) 001
De Graef, (2016) p. 32 no. 9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)