re = /(?i)<\/?\w+[^>]*>(*SKIP)(?!)|\b(\p{Latin})\s/i
str = 'Dziedziczenie dlugów spadkowych jest wciąż bardzo żywym tematem, pomimo korzystnej dla spadkobierców zmiany przepisów w 2015 roku, o ē której szerzej pisałem na blogu <a href="http://www.prawnik-katowice.pl/blog-prawniczy/dziedziczenie-dlugow-od-18-pazdziernika-2015-roku/">tutaj</a>.
'
subst = '\\1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result