using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">(.*)<|data-event-title=""([^*]*.).*""";
string input = @"data-event-title=""Yuichi Sugita* vs Adrian Mannarino"">
<span class=""odds-container"">
<b class=""odds"">1/12</b>
</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}