$re = '/^(?![#\/.])(?!.*[#\/.]$).*/m';
$str = 'path/
/path
/folder/path/
/folder/folder/path
/folder/path#hash
/folder/path.ext
path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);