# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+)\n(.+)\n(.+)(\n|$)/$1, $2, $3/gm;t' <<< "John Stave, Elon Mask
Amazon Inc
Michigan, Mi.
EAAlon MasBBk
Facebook Inc
New York, Ny."