#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.+)\n(.+)\n(.+)(\n|$)"
Local $sString = "John Stave, Elon Mask" & @CRLF & _
"Amazon Inc" & @CRLF & _
"Michigan, Mi." & @CRLF & _
"" & @CRLF & _
"EAAlon MasBBk" & @CRLF & _
"Facebook Inc" & @CRLF & _
"New York, Ny."
Local $sSubst = "$1, $2, $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)