$re = '/(.+)\n(.+)\n(.+)(\n|$)/m';
$str = 'John Stave, Elon Mask
Amazon Inc
Michigan, Mi.
EAAlon MasBBk
Facebook Inc
New York, Ny.';
$subst = "$1, $2, $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;