re = /Detection Date:.*?\*\*(.+?)\*\*.*?Confidence:/m
str = 'Detection Date:
**01/20/2015**
Confidence:'
# Print the match result
str.match(re) do |match|
puts match.to_s
end