using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<h1\s+)([^<]*?>)";
string input = @"<h1 class='' id='' title=''>Title1</h1>
<h1 class='' id='' title=''>Title2</h1>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}