#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)"
Local $sString = "Updating 46fea4e..6818c16" & @CRLF & _
"Fast-forward" & @CRLF & _
" cogs/dev.py | 2 +-" & @CRLF & _
" 1 file changed, 1 insertion(+), 1 deletion(-)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"From https://github.com/JohnnyJTH/Geri_Bot" & @CRLF & _
" 46fea4e..6818c16 master -> origin/master"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")