// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)").unwrap();
let string = "Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}