import Foundation
let pattern = #"((?:[a-zA-Z-_]*/)+)?([a-z]+\.py)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Updating 46fea4e..6818c16
Fast-forward
cogs/dev.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From https://github.com/JohnnyJTH/Geri_Bot
46fea4e..6818c16 master -> origin/master
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)