const regex = /^
(?:
(?:(?=\D*\d)(?=[^a-z]*[a-z]))
|
(?:(?=\D*\d)(?=[^!?€%&]*[!?€%&]))
|
(?:(?=\D*\d)(?=[^A-Z]*[A-Z]))
|
(?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))
|
(?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))
|
(?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))
)
.+
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?:
(?:(?=\\D*\\d)(?=[^a-z]*[a-z]))
|
(?:(?=\\D*\\d)(?=[^!?€%&]*[!?€%&]))
|
(?:(?=\\D*\\d)(?=[^A-Z]*[A-Z]))
|
(?:(?=[^a-z]*[a-z])(?=[^!?€%&]*[!?€%&]))
|
(?:(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z]))
|
(?:(?=[^!?€%&]*[!?€%&])(?=[^A-Z]*[A-Z]))
)
.+
$', 'gm')
const str = `
1 digit
1 lowercase character
1 special character (!?€%&, etc)
1 uppercase character
1A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}