#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*)\n.*$"
Local $sString = "Sample 1" & @CRLF & _
"James B. Lapointe" & @CRLF & _
"1481 Keyser Ridge Road" & @CRLF & _
"Archdale, NC 27263" & @CRLF & _
"Appartment Keyser Ridge Road" & @CRLF & _
"Archdale, NC 27263" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")