#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^[-0-9*?]{5,}$"
Local $sString = "568955" & @CRLF & _
"456646666" & @CRLF & _
"5645998989" & @CRLF & _
"5689?45" & @CRLF & _
"59-*?" & @CRLF & _
"59*-8" & @CRLF & _
"-*?**" & @CRLF & _
"???????????" & @CRLF & _
"*-*-*??" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")