$re = '/(?:[^7]*7){4}([^7]*)/';
$str = 'edbe801bf92fe7b770f72df2d722df0a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);