$re = '/.*\/([^\/]+)\/?$/';
$str = 'https://siteadress/users/username/';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;