using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\&)(?![^<]*>|[<>]*<\/)";
string input = @"& <a href=""http://www.google.com?a=b&c=d""> & </a> &
& <a href=""http://www.google.com?a=b&c=d""> & </a> &
&  &
& all the amps on this line should match [ & ] (&) [ &] ( & ) [& ] (& )[&] ( &) &
& <a href=""http://www.google.com?a=b&c=d""> & </a> &
& <a href=""http://www.google.com?a=b&c=d""> & </a> && <a href=""http://www.google.com?a=b&c=d""> & </a> && <a href=""http://www.google.com?a=b&c=d""> & </a> &
& <a href=""http://www.google.com?a=b&c=d""> & </a> &
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}