#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)color:\s*#\w+|pid=\d+#\w+|(#\w+)"
Local $sString = "<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#hello#how#are#you" & @CRLF & _
"<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#lalala #hello" & @CRLF & _
"<div class="post_body" id="pid_58705">" & @CRLF & _
"<blockquote><cite><span> (Hoy 02:42)</span>Moroha escribió: <a class="quick_jump" href="http://test.com/Thread-hello?pid=58672#pid58672" rel="nofollow"> </a></cite>testing</blockquote></div>" & @CRLF & _
"pid=97589735935795358672#foobar" & @CRLF & _
"<span style='color: #FFAABB'><a href='?pid=55155#pid55155'>hey #hello</a></span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")