use strict;
my $str = '<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#hello#how#are#you
<span style="font-weight: bold;">test1<span style="color: #FFA500;">test2</span>test3</span>#lalala #hello
<div class="post_body" id="pid_58705">
<blockquote><cite><span> (Hoy 02:42)</span>Moroha escribió: <a class="quick_jump" href="http://test.com/Thread-hello?pid=58672#pid58672" rel="nofollow"> </a></cite>testing</blockquote></div>
pid=97589735935795358672#foobar
<span style=\'color: #FFAABB\'><a href=\'?pid=55155#pid55155\'>hey #hello</a></span>';
my $regex = qr/color:\s*#\w+|pid=\d+#\w+|(#\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}