use strict;
my $str = '<iframe src="http://flashx.tv/embed-76oom84mwi54-640x360.html" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="640" height="360"></iframe>
<a href="http://fullpeliculas.com/mcfarland-usa/">
<div class="im">
<img src="http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg">
</div>
<p>
McFarland: Sin lĂmites</p></a>';
my $regex = qr/<iframe[^>]*src=[\"|']([^'\"]+)[\"|'][^>]*>/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}