import Foundation
let pattern = #"<iframe[^>]*src=[\"|']([^'\"]+)[\"|'][^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<iframe src="http://flashx.tv/embed-76oom84mwi54-640x360.html" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="640" height="360"></iframe>
<a href="http://fullpeliculas.com/mcfarland-usa/">
<div class="im">
<img src="http://fullpeliculas.com/wp-content/uploads/2014/11/McFarland-USA-150x150.jpg">
</div>
<p>
McFarland: Sin lĂmites</p></a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}