# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{5})(\d{7})(\d+)?$/$1-$2-$3/gm;t' <<< "111112222222
1111122222223"