#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{5})(\d{7})(\d+)?$"
Local $sString = "111112222222" & @CRLF & _
"1111122222223"
Local $sSubst = "$1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)