using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{5})(\d{7})(\d+)?$";
string substitution = @"$1-$2-$3";
string input = @"111112222222
1111122222223";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}