// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{5})(\d{7})(\d+)?$").unwrap();
let string = "111112222222
1111122222223";
let substitution = "$1-$2-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}