const regex = new RegExp('^(?P<ip>.*?) - - \\[(?P<date>.*?)(?= ) (?P<timezone>.*?)\\] \\"(?P<request_method>.*?) (?P<path>.*\\.php.*?)(?P<request_version> HTTP/.*)?\\" (?P<status>(301|404)?) (?P<length>.*?) \\"(?P<referrer>.*?)\\" \\"(?P<user_agent>.*?)\\"$', 'g')
const str = `66.249.69.152 - - [21/Apr/2019:00:17:11 +0300] "GET /assets/files/xt9jrjx/xvzbuoq.php?uonaemsxx=top-news-widgets HTTP/1.1" 404 3713 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}