use strict;
my $str = '012345m67890man';
my $regex = qr/(man)|[^0-9]/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";