$re = '/(man)|[^0-9]/';
$str = '012345m67890man';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;