$re = '/(?<=^\{)(.*?)(\d*?)(?=\}$)/m';
$str = '// Good names with ids
{Slitter10}
{Slitter 10}
{Slitter 10}
{Back score 22}
{Back-score 22}
{{Back-score}22}
// Good names no id
{Reference}
{Back-score}
{{Back-score}}
{{Back-score22}}
// Bad names
{Slitter10}Test
Test{Slitter10}
Test{Slitter10}Test
{Slitter10
Slitter10}
Slitter10
Slitter 10
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);