#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$"
Local $sString = "<!--#include file="test" set="one" two="asdf" -->" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)