const regex = new RegExp('^\\<\\!\\-\\-\\#([a-z]+?)\\s([a-z]*\\=\\".*\\")+? \\-\\-\\>$', 'gm')
const str = `<!--#include file="test" set="one" two="asdf" -->
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);