using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SomeText#(?:(.*?BACKUP) )?(?P<jobFileList>(?(1)[^ ]*|.*$))";
string input = @"SomeText#""C:\\"",""Shadow Copy Components:\\"",""E:\\"",""
SomeText#""D:\\""
SomeText#""E:\\"",""Shadow Copy Components:\\""
SomeText#""SET SNAP_ID=serv.a.x.com_1380312019"",""BACKUP H:\\ USING \\\\?\\GLOBALROOT\\Device\\HarddiskVolumeShadowCopy47\\OPTIONS:ALT_PATH_PREFIX=c:\\VERITAS\\NetBackup\\temp\\_vrts_frzn_img_3200\""
SomeText#""SET SNAP_ID=serv.a.x.com_1380312019"",""BACKUP Y:\\Libs USING \\\\?\\GLOBALROOT\\Device\\HarddiskVolumeShadowCopy47\\OPTIONS:ALT_PATH_PREFIX=c:\\VERITAS\\NetBackup\\temp\\_vrts_frzn_img_3200\""
SomeText#/ahol5d72_1_2
SomeText#/p7ol4a1p_1_2
SomeText#Gvadag04SANDsk_Daily
SomeText#/bck_reco_a9ol5765_1_2_827497669";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}