import Foundation
let pattern = #"\[(image)\]([^\[]+)\[(caption)\]([^\[]+)\[/\3\]\[/\1\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[image]bdaypic.jpg[caption]My pic[/caption][/image]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<figure><img src='$2'/><figcaption>$4</figcaption></figure>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)