$re = '/^(?=\d* \d*$)0[1-9 ][\d ]{9,10}$/m';
$str = '0123 122222
00213123 21
123123 1233
09 12312333
0 1111111133
01234 555 523
08374873 8
08654654 654';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);