const regex = /^[0-9]{0,7}(\.[0-9]{1,2}|[0-9]{0,2})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{0,7}(\\.[0-9]{1,2}|[0-9]{0,2})$', 'gmi')
const str = `.01
1
1.01
0
1234567.89
.012
1.098
123.456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}