re = /^[0-9]{0,7}(\.[0-9]{1,2}|[0-9]{0,2})$/mi
str = '.01
1
1.01
0
1234567.89
.012
1.098
123.456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end