# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\s*Waiting Period)(?:(?:\s{2,})(.*))"
test_str = ("Waiting Period 30 days of employment 30 days of employment 30 days of employment\n"
" Benefit amount Flat $150,000 Flat $100,000 Flat $60,000\n"
" Maximum benefit $150,000 $100,000 $60,000\n"
" Contributions Noncontributory Noncontributory Noncontributory\n"
" Participation requirement 100.00% 100.00% 100.00%\n"
"---\n"
"Benefit amount Flat $40,000 Flat $20,000\n"
" Maximum benefit $40,000 $20,000\n"
" Compulsory coverage Yes Yes\n"
" Contributions Noncontributory Noncontributory\n"
"Waiting Period 30 days of employment 30 days of employment")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.