const regex = new RegExp('<table(.(?!</table>))*', 'gm')
const str = `Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don't touch this <img src="cid:1259asdhasi">.
<table>fgf</table>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);