use strict;
my $str = 'Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don\'t touch this <img src="cid:1259asdhasi">.
<table>fgf</table>';
my $regex = qr~<table(.(?!</table>))*~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";