import Foundation
let pattern = #"<table(.(?!</table>))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Remove this tag: <img src="path/to/image">.
Also remove this tag: <img src="path/to/second/image">.
But don't touch this <img src="cid:1259asdhasi">.
<table>fgf</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)