#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*)(http\S+)(.*)$"
Local $sString = "sublimetext macro" & @CRLF & _
"https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html" & @CRLF & _
"https://docs.sublimetext.io/reference/commands.html#commands" & @CRLF & _
" https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions" & @CRLF & _
"sublime text macro replace text"
Local $sSubst = "$1* <$2>$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)