using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*)(http\S+)(.*)$";
string substitution = @"$1* <$2>$3";
string input = @"sublimetext macro
https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html
https://docs.sublimetext.io/reference/commands.html#commands
https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions
sublime text macro replace text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}