# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*word.*$//gim;t' <<< "aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse"