use strict;
my $str = 'aslkdjlsajd fjsafjlasjfg
sakjfslajf word mdsngdsnglkjds
cbcb cbfgntfh thrtjrtityi
dghdhfdh dfhdfh dfhdfjdfjdfj
sfasfsaf ryrtutru Word
detwt weyrutru kughngnse';
my $regex = qr/.*word.*$/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";