use strict;
my $str = '{1 0.78987 23.786}';
my $regex = qr/\d+(?=\.\d{5}\s)/mp;
my $subst = '8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";