import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\s+(\\w\\w\\w-\\d\\d-\\d\\d\\d\\d)\\s+(\\w+)\\s+(\\d+)\\s+(?!Created)";
final String string = "* JAN-01-2001 bugsbunny 1234 Created Module";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}