import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<\\!-* *([A-Za-z]*) *-*\\>([\\s\\S]*?)<!-* *(\\b[A-Za-z ]*\\b) *-*\\>";
final String string = "<!-- Text --><b>Text</b>\n"
+ " <a href=\"google.com\">Link</a>\n"
+ " <div class=\"col\"><h1>Nested Content</h1><p>More content</p>\n"
+ " </div>\n"
+ "<!-- END of Text -->\n"
+ "More text <!-- Another Tag Comment -->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}