import re
regex = re.compile(r"\bCisco\s+((?:(?!\bSoftware\b)[A-Za-z ])*)\s.*?Software", flags=re.MULTILINE)
test_str = ("Cisco IOS XR Software, Version 5.3.4[Default]\n\n"
"Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.4(3)M3, RELEASE SOFTWARE (fc2)\n\n"
"Cisco Nexus Operating System (NX-OS) Software\n\n"
"Cisco IOS XE Software, Version 16.05.01b\n"
"Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.5.1b, RELEASE SOFTWARE (fc1)\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")