#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:north|south)(?:\h*(?:east|west))?\b|\b(?:east|west|[NS][WE]?|[EW])\b"
Local $sString = "SHOULD MATCH:" & @CRLF & _
"405 W 1st Street South west #910" & @CRLF & _
"North, South, West, East, North East, North West, South East, South West" & @CRLF & _
" N, S, NW, NE, SE, SW, E, W." & @CRLF & _
"northeast northwest southeast southwest" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"PARTIAL MATCH:" & @CRLF & _
"north-west north-east south-west south-east" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"SHOULD NOT MATCH:" & @CRLF & _
"westnorth westsouth eastnorth eastsouth" & @CRLF & _
"wn ws en es" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")